INCIDENT PROCESSING | Perturbations plateforme de paiement / Payment platform disruptions

Incident Report for Payplug

Postmortem

English version below

Post Mortem

Référence incident

TSR-3011

Service concerné

Paiements e-commerce, 3DS et en magasins.

Impact client

Impossibilité pour les porteurs d’effectuer des paiements. 

Synthèse de l’incident

  • 2 mars 12h26 : déploiement d’une mise en production.
  • 2 mars 12h28 : début de l’incident.
  • 2 mars 12h29 : première remontée d’alerte.
  • 2 mars 12h33 : création d’une cellule de crise dédiée. Début des investigations.
  • 2 mars 12h37 : identification d’erreurs sur un service.
  • 2 mars 12h56 : identification de l’origine de l’incident.
  • 2 mars 13h : mise en place d’actions correctives.
  • 2 mars 13h01 : reprise du trafic e-commerce & 3DS.
  • 2 mars 13h38 : remontée d’erreurs sur certains paiements en magasins. Poursuite des investigations.
  • 2 mars 13h50  : identification et redémarrage des services en erreur. Fin de l’incident. 

Contexte

N/A

Root cause

Une mise en production a entraîné la mise en pause des points d’entrées des services acceptant les transactions. Ces points d’entrées étant en pause, ils n’acceptaient plus les transactions et ont causé l’interruption du trafic.

Actions à entreprendre par Payplug

Symptômes Actions
Déploiement d’une mise en production sur un horaire critique. Rappel du processus de déploiement pour éviter les mises en production sur un horaire critique.
Monitoring défaillant sur les points d’entrées des services acceptant les transactions. Renforcement du monitoring sur les points d’entrées et sur les services répartissant les transactions.
Absence de contrôle sur un certificat spécifique suite déploiement d’une mise en production. Ajout de contrôle pour vérifier l’état du certificat après déploiement d’une mise en production.

==============ENGLISH VERSION==============

Post Mortem

Incident reference

TSR-3011

Payment services affected by the incident

E-commerce payments, 3DS and in-store payments.

Client impact

Cardholders were unable to make payments.

Incident Overview

  • 2 March 12:26pm: production deployment.
  • 2 March 12:28pm: start of the incident.
  • 2 March 12:29pm: first alert raised.
  • 2 March 12:33pm: dedicated crisis team established. Investigations begin.
  • 2 March 12:37pm: errors identified on a service.
  • 2 March 12:56pm: root cause of the incident identified.
  • 2 March 1:00pm: corrective actions implemented.
  • 2 March 1:01pm: resumption of e-commerce and 3DS traffic.
  • 2 March 1:38pm: errors reported on certain in-store payments. Investigations continue.
  • 2 March 1:50pm: identification and restart of the affected services. End of the incident.

Context

N/A

Root cause

A production deployment resulted in the pausing of the entry points of the services handling transactions. As these entry points were paused, they no longer accepted transactions, which caused the interruption of traffic.

Actions to be taken by Payplug

Symptoms Actions
Production deployment carried out during a critical time window. Reminder of the deployment process to avoid production deployments during critical time windows.
Insufficient monitoring on the entry points of the services accepting transactions. Strengthening of monitoring on the entry points and on the services distributing transactions.
Lack of verification of a specific certificate following a production deployment. Addition of checks to verify the status of the certificate after a production deployment.
Posted Mar 05, 2026 - 16:10 CET

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 15:15 CET

Monitoring

TSR-3011
- Début / Start : 02/03/2026 12h28 CET
- Fin / End : 02/03/2026 13h01 CET
- Catégorie / Category : Production Processing
- Responsabilité / Responsibility : Payplug
- Priorité / Priority : P1

FR
L'incident est maintenant résolu et le service est rétabli.
Nous continuons à surveiller la reprise du service.

EN
Incident is now resolved and service restored.
Service recovery is still under monitoring.

IT
L'incidente è stato risolto e il servizio è stato ripristinato.
Continuiamo a monitorare la ripresa del servizio.
Posted Mar 02, 2026 - 13:09 CET

Investigating

FR
Nous avons identifié des difficultés sur la plateforme de paiement.
L'incident est en cours d'analyse.

EN
We have identified ongoing difficulties on the payment platform.
An investigation is in progress.

IT
Abbiamo identificato delle difficoltà nell'elaborazione dei pagamenti.
L'incidente è in fase di analisi.
Posted Mar 02, 2026 - 12:46 CET
This incident affected: Paiements e-commerce, Paiements en magasin Nexo, Paiements en magasin proxypoint, Paiements en magasin Magellan, and Moyens de paiements alternatifs.